The team is continuing to work on bringing back inbound mail flow for Zix Protect. We are working this as a high severity instance and have pulled all available resources to bring the platform back to fully operational status.
Tracking incident: IM3821977
Posted Nov 18, 2025 - 16:46 UTC
Update
We’re actively working to resolve this issue and are making progress. Please know this is a top priority for us, and we’re doing everything we can to get it resolved as quickly as possible. Thank you for your patience.
Tracking incident: IM3821977
Posted Nov 18, 2025 - 13:21 UTC
Identified
The team is actively working on the issue but have identified the underlying issue and working on bringing the platform back to operational status.
Posted Nov 18, 2025 - 01:35 UTC
Update
We are still working on resolving this issue for Zix Protect at this time. We are also seeing delays to our support@zixcorp.com address. For any tickets, please email to support@appriver.com for this.
Posted Nov 17, 2025 - 21:16 UTC
Update
We are seeing issues with delay on inbound emails and are continuing the investigation. We will update this status once we have more information.
Posted Nov 17, 2025 - 18:03 UTC
Monitoring
We have confirmed services are back and relaying mail correctly. We are actively monitoring as well to ensure no further issues.
Posted Nov 17, 2025 - 17:26 UTC
Investigating
We are currently investigating an issue with Zix Protect and inbound email. We are working on resolving this issue. We apologize for the inconvenience this may be causing.
Tracking incident: IM3821977
Posted Nov 17, 2025 - 13:27 UTC
This incident affects: Zix - Cybersecurity (Zix Support Infrastructure - Support Ticketing System, Zix Threat Protection - Zix Protect).