Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 19, 2025 - 03:00 UTC
Update
The maintenance window has been updated to reflect the correct date. Please see the updated notification below.
Zix Cybersecurity (Zix Customer Portal Interface - Customer Portal) will be undergoing system maintenance on 19 September 2025 from 03:00 to 05:00 UTC. The Customer Portal may have periods of inaccessibility or degraded functionality during this window of time.
If you require immediate assistance, please contact our Support teams via phone at 888-576-4949 or via email to support@appriver.com
Tracking Number: C2207814
Posted Sep 17, 2025 - 14:59 UTC
Update
Zix Cybersecurity (Zix Customer Portal Interface - Customer Portal) will be undergoing system maintenance on 18 September 2025 from 03:00 to 05:00 UTC. The Customer Portal may have periods of inaccessibility or degraded functionality during this window of time.
If you require immediate assistance, please contact our Support teams via phone at 888-576-4949 or via email to support@appriver.com
Tracking Number: C2207814
Posted Sep 17, 2025 - 12:44 UTC
Scheduled
Zix Cybersecurity (Zix Customer Portal Interface - Customer Portal) will be undergoing system maintenance on 18 September 2025 from 03:00 to 05:00 UTC. The Customer Portal may have periods of inaccessibility or degraded functionality during this window of time.
If you require immediate assistance, please contact our Support teams via phone at 888-576-4949 or via email to support@appriver.com