Cloud Fax Services and Core Messaging Europe were experiencing service unavailability. Document and visibility backlogs have been cleared. The issue is now resolved. We appreciate your patience.
Tracking Number: IM3736458
Posted Jul 10, 2025 - 02:11 UTC
Update
Cloud Fax Services and Core Messaging Europe were experiencing service unavailability. Service is restored. Document and visibility backlogs are being processed. We appreciate your patience.
Tracking Number: IM3736458
Posted Jul 10, 2025 - 01:12 UTC
Monitoring
Cloud Fax Services and Core Messaging Europe were experiencing service unavailability. Service is now restored. Document and visibility backlogs are being processed. We appreciate your patience.
Tracking Number: IM3736458
Posted Jul 10, 2025 - 00:12 UTC
Update
Cloud Fax Services and Core Messaging Europe are experiencing service unavailability. Document and visibility backlogs exists. Teams are assembled and are troubleshooting the issue. We appreciate your patience.
Tracking Number: IM3736458
Posted Jul 09, 2025 - 23:29 UTC
Investigating
Cloud Fax Services and Core Messaging Europe are experiencing service unavailability. Document and visibility backlogs exists. Teams are assembled and are troubleshooting the issue. We appreciate your patience.
Tracking Number: IM3736458
Posted Jul 09, 2025 - 23:12 UTC
This incident affected: Cloud Fax services Europe (Desktop Messaging BMS, Fax Cloud Connect, Fax2Mail, Production Messaging).