IM3953059 - Zix - Hosted Exchange (HEX) - New reports of Outlook connection issues

Incident Report for OpenText

Resolved

This incident has been resolved.
Posted Jul 01, 2026 - 13:35 UTC

Monitoring

We have deployed a fix that has resolved the issue. The team is continuing to monitor the system closely to ensure everything remains stable.
Tracking Number: IM3953059
Posted Jun 30, 2026 - 12:25 UTC

Investigating

Zix - Hosted Exchange (HEX) - Our engineering team is currently investigating new reports of Outlook connection issues in the EMEA region. Teams are currently assembled and working to resolve the issue. We appreciate your patience.
Tracking Number: IM3953059
Posted Jun 30, 2026 - 11:07 UTC
This incident affected: Zix - Cybersecurity (Zix Hosted Exchange).