Monitoring - Zix Hosted Exchange - Our teams have not identified any service-side issues at this time and will continue to closely monitor the environment for any further reports or signs of impact. Tracking Number: IM3958701
Posted Jul 10, 2026 - 12:19 UTC
Update
Investigating - Zix Hosted Exchange teams continue to investigate reports of intermittent slowness when accessing email through OWA and Outlook desktop. No server-side issues have been identified at this time, and the investigation remains ongoing. We appreciate your patience and will provide further updates as information becomes available. Tracking Number: IM3958701
Posted Jul 09, 2026 - 19:07 UTC
Investigating
Zix - Hosted Exchange is currently receiving reports of slowness accessing email via OWA and Outlook desktop. Teams are currently assembled and working to investigate the issue. We appreciate your patience. Tracking Number: IM3958701
Posted Jul 09, 2026 - 15:20 UTC
This incident affects: Zix - Cybersecurity (Zix Hosted Exchange).