Zix - Hosted Exchange - Mailboxes unable to connect - OWA/Outlook

Incident Report for OpenText

Resolved

This incident has been resolved.
Posted Jul 13, 2026 - 18:10 UTC

Monitoring

Zix - Hosted Exchange experienced an issue with some mailboxes unable to connect. Service has been restored and is now being validated. We appreciate your patience.
Tracking Number: IM3960496
Posted Jul 13, 2026 - 15:27 UTC

Investigating

Zix - Hosted Exchange is currently experiencing an issue with some mailboxes unable to connect. Teams are currently assembled and working to resolve the issue. We appreciate your patience.
Tracking Number: IM3960496
Posted Jul 13, 2026 - 14:02 UTC
This incident affected: Zix - Cybersecurity (Zix Hosted Exchange).