Zix- Hosted Exchange - Unable to load OWA / Outlook

Incident Report for OpenText

Resolved

This incident has been resolved.
Posted Sep 05, 2025 - 14:41 UTC

Monitoring

Zix - Hosted Exchange experienced an issue with some mailboxes unable to load OWA or Outlook. Service has been restored and is now being validated. We appreciate your patience.
Tracking Number: IM3774229
Posted Sep 05, 2025 - 14:01 UTC

Investigating

Zix- Hosted Exchange is currently experiencing an issue with some mailboxes unable to load OWA or Outlook. Teams are currently assembled and working to resolve the issue. We appreciate your patience.
Tracking Number: IM3774229
Posted Sep 05, 2025 - 13:31 UTC
This incident affected: Zix - Cybersecurity (Zix Secure Hosted Exchange - Exchange 2013/2016+ (EXG7)).