Zix Customer Portal is unreachle

Incident Report for OpenText

Resolved

We have confirmed the Customer Portal is not fully reachable and operational.
Posted Sep 04, 2025 - 14:05 UTC

Investigating

We are currently investigating an issue with the Customer Portal being unreachable via web browser. We apologize for any inconvenience this may be causing.
Posted Sep 04, 2025 - 12:15 UTC
This incident affected: Zix - Cybersecurity (Zix Customer Portal Interface - Customer Portal).