Zix - Hosted Exchange - OWA Error

Incident Report for OpenText

Resolved

This incident has been resolved.
Posted Aug 26, 2025 - 19:33 UTC

Monitoring

Zix - Hosted Exchange experienced an issue with some mailboxes unable to access OWA. The issue is now resolved. Service has been restored and is now being validated. We appreciate your patience.
Tracking Number: IM3767906
Posted Aug 26, 2025 - 19:33 UTC

Investigating

Zix - Hosted Exchange is currently experiencing an issue with some mailboxes unable to access OWA. Teams are currently assembled and working to resolve the issue. We appreciate your patience.
Tracking Number: IM3767906
Posted Aug 26, 2025 - 16:43 UTC
This incident affected: Zix - Cybersecurity (Zix Secure Hosted Exchange - Exchange 2013/2016+ (EXG7)).