Cloud Fax Services North America Maintenance scheduled for 8 February 2026

Scheduled for Feb 8, 03:00 - 11:00 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Jan 06, 2026 - 06:20 UTC

Scheduled

Cloud Fax Services North America will be undergoing network maintenance on 8 February 2026 from 3:00 to 11:00 UTC. Intermittent service interruptions are expected to occur throughout this timeframe.

If the maintenance is unable to be performed on the date specified above, it may be rescheduled to 8 March 2026. An updated post will be made if the backup date is required.

Tracking Number: C1975176
Posted Jan 06, 2026 - 05:37 UTC
This scheduled maintenance affects: Cloud Fax services North America (Desktop Messaging BMS).