Server Backup US East (Boyers) experienced login issues

Incident Report for OpenText

Resolved

Server Backup US East (Boyers) experienced login issues with the Iron Mountain portal. The issue is now resolved. We appreciate your patience.

Tracking Number: IM3957043
Posted Jul 07, 2026 - 18:20 UTC

Update

Server Backup US East (Boyers) is currently experiencing login issues with the Iron Mountain portal. Teams are currently assembled and working to resolve the issue. We appreciate your patience.

Updates for this issue will be sent every 2 hours or if there are significant updates, whichever comes first.

Tracking Number: IM3957043
Posted Jul 07, 2026 - 17:40 UTC

Update

Server Backup US East (Boyers) is currently experiencing login issues with the Iron Mountain portal. Teams are currently assembled and working to resolve the issue. We appreciate your patience.

Tracking Number: IM3957043
Posted Jul 07, 2026 - 16:42 UTC

Investigating

Server Backup US East (Boyers) is currently experiencing login issues with the Iron Mountain portal. Teams are currently assembled and working to resolve the issue. We appreciate your patience.

Tracking Number: IM3957043
Posted Jul 07, 2026 - 15:42 UTC
This incident affected: Server Backup (Server Backup US East).