XM SendSecure - US experienced an issue

Incident Report for OpenText

Resolved

XM SendSecure - US experienced an issue. Customers were unable to send or receive messages. The issue is now resolved. We appreciate your patience.

Tracking Number: IM3895665
Posted Mar 25, 2026 - 22:33 UTC

Monitoring

XM SendSecure - US experienced an issue. Customers were unable to send or receive messages. Service has been restored and is now being validated. We appreciate your patience.

Tracking Number: IM3895665
Posted Mar 25, 2026 - 22:14 UTC

Investigating

XM SendSecure - US is currently experiencing an issue. Customers are unable to send or receive messages. Teams are currently assembled and troubleshooting the issue. We appreciate your patience.

Tracking Number: IM3895665
Posted Mar 25, 2026 - 21:20 UTC
This incident affected: Cloud Fax services North America (XM SendSecure).