Zix - Hosted Exchange (HEX) - OWA Error

Incident Report for OpenText

Monitoring

Hosted Exchange (HEX) experienced an issue with some mailboxes unable to log into OWA. Service has been restored and is now being validated. We appreciate your patience.
Tracking Number: IM3731388
Posted Jul 01, 2025 - 19:05 UTC

Investigating

Hosted Exchange (HEX) is currently experiencing an issue with some mailboxes unable to log into OWA. Teams are currently assembled and working to resolve the issue. We appreciate your patience.
Tracking Number: IM3731388
Posted Jul 01, 2025 - 18:33 UTC
This incident affects: Zix - Cybersecurity (Zix Secure Hosted Exchange - Exchange 2013/2016+ (EXG7)).