Supplier Portal was experiencing an issue.
Incident Report for OpenText
Resolved
Supplier Portal for the following clients was experiencing an issue:

- Ford
- Jaguar Land Rover
- Mitsubishi
- Delphi Technologies/Phinia

The issue is now resolved. We appreciate your patience.

Tracking Number: IM3515307
Posted Jul 15, 2024 - 18:26 UTC
Update
Supplier Portal for the following clients is currently experiencing an issue:

- Ford
- Jaguar Land Rover
- Mitsubishi
- Delphi Technologies/Phinia

Teams are currently assembled and working to resolve the issue. We appreciate your patience.

Tracking Number: IM3515307
Posted Jul 15, 2024 - 18:15 UTC
Investigating
Supplier Portal for the following clients is currently experiencing an issue:

- Ford
- Jaguar Land Rover
- Mitsubishi
- Delphi Technologies/Phinia

Teams are currently assembled and working to resolve the issue. We appreciate your patience.

Tracking Number: IM3515307
Posted Jul 15, 2024 - 17:14 UTC
This incident affected: Supplier Portal.