MailStore Cloud was unavailable

Incident Report for OpenText

Resolved

MailStore Cloud was unavailable. The issue is now resolved. We appreciate your patience.
Posted Aug 26, 2026 - 15:57 UTC

Monitoring

MailStore Cloud was unavailable. Service has been restored and is being validated. We appreciate your patience.
Posted Aug 26, 2026 - 15:05 UTC

Investigating

MailStore Cloud is currently unavailable. Teams are currently assembled and working to resolve the issue. We appreciate your patience.
Posted Aug 26, 2026 - 14:12 UTC
This incident affected: MailStore (MailStore Cloud).