Core Fax North America was experiencing degradation in service. Backlogs have been cleared. The issue is now resolved. We appreciate your patience.
Tracking Number: IM3851319
Posted Jan 14, 2026 - 01:41 UTC
Update
Core Fax North America was experiencing degradation in service. Backlogs have been cleared. The issue is now resolved. We appreciate your patience.
Tracking Number: IM3851319
Posted Jan 14, 2026 - 01:40 UTC
Update
Core Fax North America is experiencing degradation in service. Backlogs exist. Teams are assembled and troubleshooting the issue. Updates for this issue will be sent every 2 hours or if there are significant updates, whichever comes first. We appreciate your patience. We appreciate your patience.
Tracking Number: IM3851319
Posted Jan 13, 2026 - 23:37 UTC
Update
Core Fax North America is experiencing degradation in service. Backlogs exist. Teams are assembled and troubleshooting the issue. We appreciate your patience.
Tracking Number: IM3851319
Posted Jan 13, 2026 - 22:51 UTC
Update
Core Fax North America only is experiencing degradation in service. Backlogs exist. Teams are assembled and troubleshooting the issue. We appreciate your patience.
Tracking Number: IM3851319
Posted Jan 13, 2026 - 22:34 UTC
Investigating
Core Fax Canada and North America are experiencing degradation in service. Backlogs exists. Teams are assembled and troubleshooting the issue. We appreciate your patience.