Zix - Hosted Exchange OWA/Outlook Error

Incident Report for OpenText

Resolved

This incident has been resolved.
Posted Aug 18, 2025 - 13:58 UTC

Investigating

Zix - Hosted Exchange is currently experiencing an issue with some mailboxes unable to access OWA and Outlook. Teams are currently assembled and working to resolve the issue. We appreciate your patience.
Tracking Number: IM3762391
Posted Aug 18, 2025 - 13:13 UTC
This incident affected: Zix - Cybersecurity (Zix Secure Hosted Exchange - Exchange 2013/2016+ (EXG7)).