We are to actively monitor and confirm the routing actions have restored mail flow back to full functionality since 12/6. We are continuing to work with Microsoft on the issue as well to confirm the root cause of the deferrals that occurred but are leaving our current routing actions in place until we confirm no further issues can occur.
With the re-routes occurring, please ensure customers are utilizing both our primary and secondary MX records in their DNS for mail flow.
Posted Dec 08, 2025 - 17:49 UTC
Update
We are continued to monitor as we have re-routed traffic as a workaround and continue to leave the routing in place for email delivery.
Posted Dec 08, 2025 - 13:07 UTC
Monitoring
Our team is working on re-routing traffic to help aid with delivery. It appears that Microsoft is deferring the messages from our delivery server and we are working on getting in contact with Microsoft as well.
Posted Dec 06, 2025 - 18:32 UTC
Investigating
We are currently investigating an issue in which a subset of customer that are hosted on 365 are experiencing delays to their tenant. We will update once we have further details.