Zix Hosted Exchange Mailbox Mail Delivery Issues

Incident Report for OpenText

Resolved

Zix Hosted Exchange Mailbox experienced an issue with mail delivery. Service has been restored and is now being validated. We appreciate your patience.
Tracking Number: IM3838764
Posted Dec 18, 2025 - 14:06 UTC

Update

We are continuing to monitor for any further issues.
Posted Dec 17, 2025 - 17:39 UTC

Monitoring

Zix Hosted Exchange Mailbox experienced an issue with mail delivery. Service has been restored and is now being validated. We appreciate your patience.
Tracking Number: IM3838764
Posted Dec 17, 2025 - 17:38 UTC

Update

Zix Hosted Exchange Mailbox is currently experiencing an issue with mail delivery. Teams are currently assembled and working to resolve the issue. We appreciate your patience.
Tracking Number: IM3838764
Posted Dec 17, 2025 - 16:24 UTC

Investigating

Zix Hosted Exchange Mailbox is currently experiencing an issue with mail delivery. Teams are currently assembled and working to resolve the issue. We appreciate your patience.
Tracking Number: IM3838764
Posted Dec 17, 2025 - 11:53 UTC
This incident affected: Zix - Cybersecurity (Zix Secure Hosted Exchange - Exchange 2013/2016+ (EXG7)).