Cloud Fax services Europe experienced an issue

Incident Report for OpenText

Resolved

The following services experienced an issue. The issue is now resolved. We appreciate your patience.

- Fax Cloud Connect (RightFax)
- Fax2Mail
- Production Messaging

Tracking Number: IM3933644
Posted May 27, 2026 - 11:45 UTC

Investigating

The following services are currently experiencing an issue. Teams are currently assembled and working to resolve the issue. We appreciate your patience.

- Fax Cloud Connect (RightFax)
- Fax2Mail
- Production Messaging

Tracking Number: IM3933644
Posted May 27, 2026 - 11:03 UTC
This incident affected: Cloud Fax services Europe (Fax Cloud Connect (RightFax), Fax2Mail, Production Messaging).