The following services experienced a service degradation. Backlogs have been cleared. The issue is now resolved. We appreciate your patience.
Cloud Fax services Europe - Fax Cloud Connect (RightFax) - Fax2Mail - Production Messaging
Core Messaging Europe - Core Messaging - Email
Tracking Number: IM3913794
Posted Apr 23, 2026 - 08:29 UTC
Monitoring
The following services experienced a degradation in service. Service has been restored and is now being validated. Backlogs exist and currently being processed. We appreciate your patience.
Cloud Fax services Europe - Fax Cloud Connect (RightFax) - Fax2Mail - Production Messaging
Core Messaging Europe - Core Messaging - Email
Tracking Number: IM3913794
Posted Apr 23, 2026 - 08:18 UTC
Update
The following services are experiencing degradation in service. Degradation started on April 22nd at 21:55 GMT. Teams are currently assembled and working to resolve the issue. We appreciate your patience.
Cloud Fax services Europe - Fax Cloud Connect (RightFax) - Fax2Mail - Production Messaging
Core Messaging Europe - Core Messaging - Email
Tracking Number: IM3913794
Posted Apr 23, 2026 - 07:40 UTC
Investigating
The following services are experiencing degradation in service. Degradation started on April 22nd at 21:55 GMT. Teams are currently assembled and working to resolve the issue. We appreciate your patience.
Cloud Fax services Europe - Fax Cloud Connect (RightFax) - Fax2Mail - Production Messaging
Core Messaging Europe - Core Messaging - Email
Tracking Number: IM3913794
Posted Apr 23, 2026 - 06:41 UTC
This incident affected: Cloud Fax services Europe (Fax Cloud Connect (RightFax), Fax2Mail, Production Messaging) and Core Messaging Europe (Core Messaging - Email).