IM3952482 - Zix - Hosted Exchange (HEX) - Outlook Connections

Incident Report for OpenText

Update

Zix - Hosted Exchange (HEX) is currently experiencing an issue with Outlook connections in EMEA region. Teams are currently assembled and working to resolve the issue. We appreciate your patience.
Tracking Number: IM3952482
Posted Jun 29, 2026 - 14:44 UTC

Investigating

Zix - Hosted Exchange (HEX) - Our engineering team is currently investigating reports of Outlook connection issues in the EMEA region. Teams are currently assembled and working to resolve the issue. We appreciate your patience.
Tracking Number: IM3952482
Posted Jun 29, 2026 - 13:35 UTC
This incident affects: Zix - Cybersecurity (Zix Hosted Exchange).