Zix - Hosted Exchange (HEX) - OWA/Outlook error

Incident Report for OpenText

Resolved

This incident has been resolved.
Posted Mar 31, 2026 - 12:12 UTC

Monitoring

HEX experienced an issue with some mailboxes unable to connect via OWA/Outlook. Service has been restored and is now being validated. We appreciate your patience.
Tracking Number: IM3898559
Posted Mar 30, 2026 - 20:01 UTC

Investigating

HEX is currently experiencing an issue with some mailboxes unable to connect via OWA/Outlook. Teams are currently assembled and working to resolve the issue. We appreciate your patience.
Tracking Number: IM3898559
Posted Mar 30, 2026 - 19:13 UTC
This incident affected: Zix - Cybersecurity (Zix Hosted Exchange).