Zix Hosted Exchange/Customer Portal not saving updates to user settings

Incident Report for OpenText

Monitoring

Hosted Exchange user saving issues has now been restored and is now being validated. We appreciate your patience.
Tracking Number: IM3967822
Posted Jul 25, 2026 - 23:52 UTC

Investigating

Hosted Exchange is currently experiencing an issue and not saving user changes from the customer portal. Teams are currently assembled and working to resolve the issue. We appreciate your patience.
Tracking Number: IM3967822
Posted Jul 25, 2026 - 21:57 UTC
This incident affects: Zix - Cybersecurity (Zix Hosted Exchange).