Zix - Cybersecurity - Zix Encryption Services - Secure Cloud Email Encryption (AEE/ZEE) experienced an issue communicating with several service providers via TLS.
The issue is now resolved. We appreciate your patience.
Tracking Number: IM3916953
Posted Apr 28, 2026 - 23:31 UTC
Identified
Zix - Cybersecurity - Zix Encryption Services - Secure Cloud Email Encryption (AEE/ZEE) is currently experiencing an issue communicating with service providers via TLS.
Teams have identified the issue and are working to restore communications. We appreciate your patience.
Tracking Number: IM3916953
Posted Apr 28, 2026 - 21:51 UTC
Update
Zix - Cybersecurity - Zix Encryption Services - Secure Cloud Email Encryption (AEE/ZEE) is currently experiencing an issue communicating with service providers via TLS.
Teams are currently assembled and working to resolve the issue. We appreciate your patience.
Tracking Number: IM3916953
Posted Apr 28, 2026 - 19:36 UTC
Update
Zix - Cybersecurity - Zix Encryption Services - Secure Cloud Email Encryption (AEE/ZEE) is currently experiencing an issue communicating with Google Servers.
Teams are currently assembled and working to resolve the issue. We appreciate your patience.
Tracking Number: IM3916953
Posted Apr 28, 2026 - 19:24 UTC
Investigating
Zix Encryption Services - Secure Cloud Email Encryption (AEE/ZEE) is currently experiencing an issue with sending/accepting messages.
Teams are currently assembled and working to resolve the issue. We appreciate your patience.