Zix Archive Services BCA and ZixArchive experienced an issue when administrators navigated to the Archive pages of their respective interfaces.
The issue is now resolved. We appreciate your patience.
Tracking Number: IM3997654
Posted Sep 14, 2026 - 14:50 UTC
Monitoring
Zix Archive Services BCA and ZixArchive experienced an issue when administrators navigated to the Archive pages of their respective interfaces. Service has been restored and is being validated. We appreciate your patience.
Tracking Number: IM3997654
Posted Sep 14, 2026 - 13:31 UTC
Investigating
Zix Archive Services BCA and ZixArchive are currently experiencing an issue when administrators navigate to the Archive pages of their respective interfaces. Teams are currently assembled and working to resolve the issue. We appreciate your patience.
Tracking Number: IM3997654
Posted Sep 14, 2026 - 12:26 UTC
This incident affected: Zix - Cybersecurity (Zix Archive Services - Business Communication Archive, Zix Archive Services - ZixArchive).