Cloud Fax Services North America Hardware Maintenance scheduled for 15 February 2026

Scheduled for Feb 15, 03:00 - 07:00 UTC

Update

Cloud Fax Services North America will be undergoing hardware maintenance on 15 February 2026 from 3:00 to 7:00 UTC. Service will be degraded during this timeframe.

- Desktop Messaging BMS

Tracking Number: C2236468
Posted Jan 15, 2026 - 06:26 UTC

Scheduled

Cloud Fax Services North America will be undergoing hardware maintenance on 15 February 2026 from 3:00 to 7:00 UTC. Service will be degraded during this timeframe.

- Desktop Messaging BMS

Tracking Number: C2236468
Posted Jan 15, 2026 - 06:25 UTC
This scheduled maintenance affects: Cloud Fax services North America (Desktop Messaging BMS).