Zix - Hosted Exchange - OWA error

Incident Report for OpenText

Resolved

Zix - Hosted Exchange experienced an issue with some mailboxes unable to access OWA. The issue is now resolved. We appreciate your patience.
Tracking Number: IM3766968
Posted Aug 25, 2025 - 14:31 UTC

Investigating

Zix - Hosted Exchange is currently experiencing an issue with some mailboxes unable to access OWA. Teams are currently assembled and working to resolve the issue. We appreciate your patience.
Tracking Number: IM3766968
Posted Aug 25, 2025 - 13:45 UTC
This incident affected: Zix - Cybersecurity (Zix Secure Hosted Exchange - Exchange 2013/2016+ (EXG7)).