Zix Encryption Services - Secure Cloud Email Encryption (AEE/ZEE) and Hosted SMB experienced an issue with TLS negotiating with recipient mail servers. There were no additional incidents. This matter is considered to be closed.
We appreciate your patience.
Tracking Number: IM3755104
Posted Aug 07, 2025 - 13:32 UTC
Monitoring
Zix Encryption Services - Secure Cloud Email Encryption (AEE/ZEE) and Hosted SMB experienced an issue with TLS negotiating with recipient mail servers. Service has been restored and is now being validated.
We appreciate your patience.
Tracking Number: IM3755104
Posted Aug 06, 2025 - 20:55 UTC
Update
Zix Encryption Services - Secure Cloud Email Encryption (AEE/ZEE) and Hosted SMB experienced an issue with TLS negotiating with recipient mail servers. Teams are currently assembled and working to resolve the issue.
We appreciate your patience.
Tracking Number: IM3755104
Posted Aug 06, 2025 - 19:52 UTC
Investigating
Zix Encryption Services - Secure Cloud Email Encryption (AEE/ZEE) is currently experiencing an issue with its TLS certificates and negotiations with primarily Google servers. Teams are currently assembled and working to resolve the issue. We appreciate your patience.